blob: 89beaa91499bb9b9b8eb1e8cfe0c67362d78dfb9 [file] [log] [blame]
Jerry Wan77938922022-01-28 09:57:37 +08001PACKAGECONFIG:append:s6q = " sync-mac nic-ethtool"
2
3FILES:${PN}:append:s6q = " ${datadir}/network/config.json"
4
5do_install:append:s6q() {
6 install -d ${D}${datadir}/network/
7 if ${@bb.utils.contains('MACHINE_FEATURES', 'bonding', 'true', 'false', d)};
8 then
9 echo '{"bond0":"bmc","eth0":"bmc","eth1":"bmc"}' \
10 > ${D}${datadir}/network/config.json
11 else
12 echo '{"eth0":"bmc"}' > ${D}${datadir}/network/config.json
13 fi
14}