blob: a6550a9732a3614ee8f0b8ed2ecd18c693982b2a [file] [log] [blame]
SUMMARY = "The extensible, standards compliant build backend used by Hatch"
HOMEPAGE = "https://hatch.pypa.io/latest/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9"
inherit pypi python_hatchling
DEPENDS += "python3-pluggy-native python3-tomli-native python3-pathspec-native python3-packaging-native python3-editables-native"
DEPENDS:remove:class-native = "python3-hatchling-native"
SRC_URI[sha256sum] = "1401d45d3dd6a5910f64d539acaa943486d5e8b7dda1a97f2b0040fdddc5b85e"
# Until we have a proper tool to invoke PEP517 builds, hatchling can't
# bootstrap itself automatically.
PEP517_BUILD_API = "hatchling.ouroboros"
do_compile:prepend() {
export PYTHONPATH=src
}
BBCLASSEXTEND = "native nativesdk"