blob: a6550a9732a3614ee8f0b8ed2ecd18c693982b2a [file] [log] [blame]
Andrew Geissler78b72792022-06-14 06:47:25 -05001SUMMARY = "The extensible, standards compliant build backend used by Hatch"
2HOMEPAGE = "https://hatch.pypa.io/latest/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9"
5
6inherit pypi python_hatchling
7
8DEPENDS += "python3-pluggy-native python3-tomli-native python3-pathspec-native python3-packaging-native python3-editables-native"
9DEPENDS:remove:class-native = "python3-hatchling-native"
10
11SRC_URI[sha256sum] = "1401d45d3dd6a5910f64d539acaa943486d5e8b7dda1a97f2b0040fdddc5b85e"
12
13# Until we have a proper tool to invoke PEP517 builds, hatchling can't
14# bootstrap itself automatically.
15PEP517_BUILD_API = "hatchling.ouroboros"
16
17do_compile:prepend() {
18 export PYTHONPATH=src
19}
20
21BBCLASSEXTEND = "native nativesdk"