blob: 5b61c06ad49af21c91a249665ab59c4ffa2565ca [file] [log] [blame]
SUMMARY = "Python project template generator with batteries included"
DESCRIPTION = "PyScaffold package helps to setup a new Python project. \
After installation, it provides a new command [putup], which could be \
used to create template Projects."
HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
SECTION = "devel/python"
LICENSE = "0BSD & MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14a49c74a1d91829908ac756c07e6b91"
DEPENDS += "python3-setuptools-scm-native"
SRC_URI[sha256sum] = "11be56d21a0047ea604e7bc4349e95592cdc734b0a405082a6a4f2a7028dc896"
inherit pypi python_setuptools_build_meta
PYPI_PACKAGE = "PyScaffold"
RDEPENDS:${PN} += " \
python3-email \
python3-compression \
"
BBCLASSEXTEND = "native nativesdk"