blob: 5b61c06ad49af21c91a249665ab59c4ffa2565ca [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Python project template generator with batteries included"
2DESCRIPTION = "PyScaffold package helps to setup a new Python project. \
3After installation, it provides a new command [putup], which could be \
4used to create template Projects."
5
6HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
7SECTION = "devel/python"
8LICENSE = "0BSD & MIT"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14a49c74a1d91829908ac756c07e6b91"
10DEPENDS += "python3-setuptools-scm-native"
11
Andrew Geissler78b72792022-06-14 06:47:25 -050012SRC_URI[sha256sum] = "11be56d21a0047ea604e7bc4349e95592cdc734b0a405082a6a4f2a7028dc896"
Andrew Geissler9aee5002022-03-30 16:27:02 +000013
14inherit pypi python_setuptools_build_meta
15PYPI_PACKAGE = "PyScaffold"
16
17RDEPENDS:${PN} += " \
18 python3-email \
19 python3-compression \
20"
21
22BBCLASSEXTEND = "native nativesdk"