blob: 15d92065d0962c629d63d6d0825a33f1a0a84d81 [file] [log] [blame]
SUMMARY = "The module provides handy URL class for url parsing and changing"
HOMEPAGE = "https://github.com/aio-libs/yarl/"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
SRC_URI[md5sum] = "08ba0d6e18f460b44d9e5459f3d217ba"
SRC_URI[sha256sum] = "58cd9c469eced558cd81aa3f484b2924e8897049e06889e8ff2510435b7ef74b"
SRC_URI += " \
file://run-ptest \
"
PYPI_PACKAGE = "yarl"
inherit pypi ptest setuptools3
RDEPENDS_${PN} = "\
${PYTHON_PN}-multidict \
${PYTHON_PN}-idna \
"
RDEPENDS_${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}