blob: 15d92065d0962c629d63d6d0825a33f1a0a84d81 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
5
6SRC_URI[md5sum] = "08ba0d6e18f460b44d9e5459f3d217ba"
7SRC_URI[sha256sum] = "58cd9c469eced558cd81aa3f484b2924e8897049e06889e8ff2510435b7ef74b"
8
9SRC_URI += " \
10 file://run-ptest \
11"
12
13PYPI_PACKAGE = "yarl"
14
15inherit pypi ptest setuptools3
16
17RDEPENDS_${PN} = "\
18 ${PYTHON_PN}-multidict \
19 ${PYTHON_PN}-idna \
20"
21
22RDEPENDS_${PN}-ptest += " \
23 ${PYTHON_PN}-pytest \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}