blob: f7863d4e7652a3da0f1bbc69673af8a54d7e688f [file] [log] [blame]
SUMMARY = "Phosphor Power Sequencer services installation"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
PR = "r1"
inherit allarch
RDEPENDS:${PN} += "phosphor-power-sequencer"
pkg_prerm:${PN}() {
LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service"
rm $LINK
LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service"
rm $LINK
}
pkg_postinst:${PN}() {
mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants
mkdir -p $D$systemd_system_unitdir/multi-user.target.requires
LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service"
TARGET="../pseq-monitor.service"
ln -s $TARGET $LINK
LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service"
TARGET="../pseq-monitor-pgood.service"
ln -s $TARGET $LINK
}
ALLOW_EMPTY:${PN} = "1"