blob: f7863d4e7652a3da0f1bbc69673af8a54d7e688f [file] [log] [blame]
Lei YU7307bed2020-02-06 15:43:35 +08001SUMMARY = "Phosphor Power Sequencer services installation"
Lei YU7307bed2020-02-06 15:43:35 +08002LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ed Tanous9936f862022-09-19 09:13:20 -07004PR = "r1"
Lei YU7307bed2020-02-06 15:43:35 +08005
6inherit allarch
7
Patrick Williams12fc9392021-08-06 09:16:53 -05008RDEPENDS:${PN} += "phosphor-power-sequencer"
Lei YU7307bed2020-02-06 15:43:35 +08009
Patrick Williams12fc9392021-08-06 09:16:53 -050010pkg_prerm:${PN}() {
Ed Tanous9936f862022-09-19 09:13:20 -070011 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service"
12 rm $LINK
13 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service"
14 rm $LINK
Lei YU7307bed2020-02-06 15:43:35 +080015}
Ed Tanous9936f862022-09-19 09:13:20 -070016pkg_postinst:${PN}() {
17 mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants
18 mkdir -p $D$systemd_system_unitdir/multi-user.target.requires
19 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service"
20 TARGET="../pseq-monitor.service"
21 ln -s $TARGET $LINK
22 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service"
23 TARGET="../pseq-monitor-pgood.service"
24 ln -s $TARGET $LINK
25}
26
27ALLOW_EMPTY:${PN} = "1"