blob: f2abc3cd503e31c496d0b2a657f8efbe4e86c4cf [file] [log] [blame]
require recipes-graphics/xorg-app/xorg-app-common.inc
SUMMARY = "xterm is the standard terminal emulator for the X Window System"
DEPENDS = "libxaw xproto xextproto libxext libxau libxinerama libxpm ncurses"
LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=ee6435019d00b884cde8d7ba2b318ff0"
SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz"
SRC_URI[md5sum] = "0d7f0e6390d132ae59876b3870e5783d"
SRC_URI[sha256sum] = "a60dbb574334c081425fa30f011cd9f571e3be7a91e2a84e252461798bce24a7"
PACKAGECONFIG ?= ""
PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native"
EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
--x-libraries=${STAGING_LIBDIR} \
FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
--disable-imake \
--disable-rpath-hack \
--disable-setuid"
B = "${S}"
do_configure() {
gnu-configize --force
sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
oe_runconf
}
FILES_${PN} += "${libdir}/X11"