blob: f2abc3cd503e31c496d0b2a657f8efbe4e86c4cf [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001require recipes-graphics/xorg-app/xorg-app-common.inc
2SUMMARY = "xterm is the standard terminal emulator for the X Window System"
3DEPENDS = "libxaw xproto xextproto libxext libxau libxinerama libxpm ncurses"
4
5LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=ee6435019d00b884cde8d7ba2b318ff0"
6
7SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz"
8
9SRC_URI[md5sum] = "0d7f0e6390d132ae59876b3870e5783d"
10SRC_URI[sha256sum] = "a60dbb574334c081425fa30f011cd9f571e3be7a91e2a84e252461798bce24a7"
11
12PACKAGECONFIG ?= ""
13PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native"
14
15EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
16 --x-libraries=${STAGING_LIBDIR} \
17 FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
18 --disable-imake \
19 --disable-rpath-hack \
20 --disable-setuid"
21
22B = "${S}"
23
24do_configure() {
25 gnu-configize --force
26 sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
27 oe_runconf
28}
29
30FILES_${PN} += "${libdir}/X11"