blob: 371e1abbb72b53075ed2a08a1d6c485bcc9d792e [file] [log] [blame]
SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
HOMEPAGE = "http://www.libssh.org"
SECTION = "libs"
DEPENDS = "zlib openssl libgcrypt"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7"
SRCREV = "053f72c671a83b32238dc01b56a66752fb15b7ec"
S = "${WORKDIR}/git"
EXTRA_OECMAKE = " \
-DWITH_GCRYPT=1 \
-DWITH_PCAP=1 \
-DWITH_SFTP=1 \
-DWITH_ZLIB=1 \
-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')} \
"
PACKAGECONFIG ??=""
PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
inherit cmake
do_configure_prepend () {
# Disable building of examples
sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
|| bbfatal "Failed to disable examples"
}
FILES_${PN}-dev += "${libdir}/cmake"