blob: 371e1abbb72b53075ed2a08a1d6c485bcc9d792e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
2HOMEPAGE = "http://www.libssh.org"
3SECTION = "libs"
4
5DEPENDS = "zlib openssl libgcrypt"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
9
10SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-7"
11SRCREV = "053f72c671a83b32238dc01b56a66752fb15b7ec"
12S = "${WORKDIR}/git"
13
14EXTRA_OECMAKE = " \
15 -DWITH_GCRYPT=1 \
16 -DWITH_PCAP=1 \
17 -DWITH_SFTP=1 \
18 -DWITH_ZLIB=1 \
19 -DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')} \
20 "
21
22PACKAGECONFIG ??=""
23PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
24
25inherit cmake
26
27do_configure_prepend () {
28 # Disable building of examples
29 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
30 || bbfatal "Failed to disable examples"
31}
32
33FILES_${PN}-dev += "${libdir}/cmake"