blob: 803c1b46f478b736c77ec3ffb41c57e513c8b8ee [file] [log] [blame]
SUMMARY = "Phosphor OpenBMC MBOX Daemon"
DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit autotools pkgconfig
inherit obmc-phosphor-systemd
DEPENDS += "autoconf-archive-native"
S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/mboxbridge.git;protocol=https"
SRC_URI += "file://99-aspeed-mbox.rules"
SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
SRCREV="8cb799c2d6c2675959e80f2a7b88610aa4f4817a"
MBOXD_FLASH_SIZE ??= "32M"
SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
CFLAGS_append = "-I include"
do_install_append() {
install -d ${D}/lib/udev/rules.d
install -m 0644 ${WORKDIR}/99-aspeed-mbox.rules ${D}/lib/udev/rules.d
}