blob: 803c1b46f478b736c77ec3ffb41c57e513c8b8ee [file] [log] [blame]
Cyril Burb73580e2017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-systemd
9
10DEPENDS += "autoconf-archive-native"
11
12S = "${WORKDIR}/git"
13
14SRC_URI += "git://github.com/openbmc/mboxbridge.git;protocol=https"
15
16SRC_URI += "file://99-aspeed-mbox.rules"
17SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
18
19SRCREV="8cb799c2d6c2675959e80f2a7b88610aa4f4817a"
20
21MBOXD_FLASH_SIZE ??= "32M"
22SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
23
24# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
25# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
26CFLAGS_append = "-I include"
27
28do_install_append() {
29 install -d ${D}/lib/udev/rules.d
30 install -m 0644 ${WORKDIR}/99-aspeed-mbox.rules ${D}/lib/udev/rules.d
31}