blob: 89538d2f272b213c7f993dd7be0b80d48206edbd [file] [log] [blame]
DESCRIPTION = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
SRC_URI[sha256sum] = "89aab215427ef59c34ad58735269eb58b1a5808103067f7bb9d5836c651b3bb0"
PYPI_PACKAGE = "Jinja2"
CLEANBROKEN = "1"
inherit pypi setuptools3
# ptest disabled in OE-Core for now due to missing dependencies
SRC_URI += " \
file://run-ptest \
"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
RDEPENDS_${PN}-ptest += " \
${PYTHON_PN}-pytest \
${PYTHON_PN}-unixadmin \
"
RDEPENDS_${PN} += " \
${PYTHON_PN}-asyncio \
${PYTHON_PN}-crypt \
${PYTHON_PN}-io \
${PYTHON_PN}-json \
${PYTHON_PN}-markupsafe \
${PYTHON_PN}-math \
${PYTHON_PN}-netclient \
${PYTHON_PN}-numbers\
${PYTHON_PN}-pickle \
${PYTHON_PN}-pprint \
${PYTHON_PN}-shell \
${PYTHON_PN}-threading \
"
BBCLASSEXTEND = "native nativesdk"