blob: 89538d2f272b213c7f993dd7be0b80d48206edbd [file] [log] [blame]
Andrew Geisslerc3d88e42020-10-02 09:45:00 -05001DESCRIPTION = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
5
6SRC_URI[sha256sum] = "89aab215427ef59c34ad58735269eb58b1a5808103067f7bb9d5836c651b3bb0"
7
8PYPI_PACKAGE = "Jinja2"
9
10CLEANBROKEN = "1"
11
12inherit pypi setuptools3
13# ptest disabled in OE-Core for now due to missing dependencies
14
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25RDEPENDS_${PN}-ptest += " \
26 ${PYTHON_PN}-pytest \
27 ${PYTHON_PN}-unixadmin \
28"
29
30RDEPENDS_${PN} += " \
31 ${PYTHON_PN}-asyncio \
32 ${PYTHON_PN}-crypt \
33 ${PYTHON_PN}-io \
34 ${PYTHON_PN}-json \
35 ${PYTHON_PN}-markupsafe \
36 ${PYTHON_PN}-math \
37 ${PYTHON_PN}-netclient \
38 ${PYTHON_PN}-numbers\
39 ${PYTHON_PN}-pickle \
40 ${PYTHON_PN}-pprint \
41 ${PYTHON_PN}-shell \
42 ${PYTHON_PN}-threading \
43"
44
45BBCLASSEXTEND = "native nativesdk"