blob: 945b43d9f61fd42da8384a68cf3a82061e3ccb62 [file] [log] [blame]
DESCRIPTION = "Linux kernel for OpenBMC"
SECTION = "kernel"
LICENSE = "GPLv2"
KBRANCH ?= "dev-4.4"
KCONFIG_MODE="--alldefconfig"
SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
LINUX_VERSION ?= "4.4"
LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
SRCREV="openbmc-20160511-1"
PV = "${LINUX_VERSION}+git${SRCPV}"
COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
do_patch_append() {
for DTB in "${KERNEL_DEVICETREE}"; do
DT=`basename ${DTB} .dtb`
if [ -r "${WORKDIR}/${DT}.dts" ]; then
cp ${WORKDIR}/${DT}.dts \
${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
fi
done
}