blob: 945b43d9f61fd42da8384a68cf3a82061e3ccb62 [file] [log] [blame]
Joel Stanley8ef9fee2016-03-21 12:24:40 +10301DESCRIPTION = "Linux kernel for OpenBMC"
2SECTION = "kernel"
3LICENSE = "GPLv2"
4
5KBRANCH ?= "dev-4.4"
6KCONFIG_MODE="--alldefconfig"
7
8SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
9
10LINUX_VERSION ?= "4.4"
11LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
12
Joel Stanley369f4d62016-05-11 15:00:42 +093013SRCREV="openbmc-20160511-1"
Joel Stanley8ef9fee2016-03-21 12:24:40 +103014
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
18
19inherit kernel
20require recipes-kernel/linux/linux-yocto.inc
Brad Bishopd1bcf3d2016-05-06 20:35:43 -040021
22do_patch_append() {
23 for DTB in "${KERNEL_DEVICETREE}"; do
24 DT=`basename ${DTB} .dtb`
25 if [ -r "${WORKDIR}/${DT}.dts" ]; then
26 cp ${WORKDIR}/${DT}.dts \
27 ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
28 fi
29 done
30}