blob: cab5d6c132fa18b8ed1efeb7e115b536cdd3fe7b [file] [log] [blame]
SUMMARY = "Management Component Control Protocol utilities"
HOMEPAGE = "http://www.github.com/CodeConstruct/mctp"
SECTION = "net"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4cc91856b08b094b4f406a29dc61db21"
SRCREV = "a8658290b7914f67146a982671b09f2270ba1654"
SRC_URI = "git://github.com/CodeConstruct/mctp;branch=main"
S = "${WORKDIR}/git"
inherit meson pkgconfig systemd
PACKAGECONFIG ??= " \
${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
"
# mctpd will only be built if pkg-config detects libsystemd; in which case
# we'll want to declare the dep and install the service.
PACKAGECONFIG[systemd] = ",,systemd,libsystemd"
SYSTEMD_SERVICE:${PN} = "mctpd.service"
do_install:append () {
if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${S}/conf/mctpd.service \
${D}${systemd_system_unitdir}/mctpd.service
fi
}