blob: cab5d6c132fa18b8ed1efeb7e115b536cdd3fe7b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Management Component Control Protocol utilities"
2HOMEPAGE = "http://www.github.com/CodeConstruct/mctp"
3SECTION = "net"
4LICENSE = "GPLv2"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4cc91856b08b094b4f406a29dc61db21"
7
8SRCREV = "a8658290b7914f67146a982671b09f2270ba1654"
9
10SRC_URI = "git://github.com/CodeConstruct/mctp;branch=main"
11
12S = "${WORKDIR}/git"
13
14inherit meson pkgconfig systemd
15
16PACKAGECONFIG ??= " \
17 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
18"
19
20# mctpd will only be built if pkg-config detects libsystemd; in which case
21# we'll want to declare the dep and install the service.
22PACKAGECONFIG[systemd] = ",,systemd,libsystemd"
23SYSTEMD_SERVICE:${PN} = "mctpd.service"
24
25do_install:append () {
26 if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then
27 install -d ${D}${systemd_system_unitdir}
28 install -m 0644 ${S}/conf/mctpd.service \
29 ${D}${systemd_system_unitdir}/mctpd.service
30 fi
31}