blob: c7b33d99ff6f48e00d1f01afc3235e333c116752 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# set the ARCH environment variable for kernel compilation (including
3# modules). return value must match one of the architecture directories
4# in the kernel source "arch" directory
5#
6
7valid_archs = "alpha cris ia64 \
8 i386 x86 \
9 m68knommu m68k ppc powerpc powerpc64 ppc64 \
10 sparc sparc64 \
11 arm aarch64 \
12 m32r mips \
13 sh sh64 um h8300 \
14 parisc s390 v850 \
15 avr32 blackfin \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050016 microblaze \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017 nios2 arc xtensa"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
19def map_kernel_arch(a, d):
20 import re
21
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022 valid_archs = d.getVar('valid_archs').split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050024 if re.match('(i.86|athlon|x86.64)$', a): return 'x86'
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025 elif re.match('armeb$', a): return 'arm'
26 elif re.match('aarch64$', a): return 'arm64'
27 elif re.match('aarch64_be$', a): return 'arm64'
Brad Bishop00111322018-04-01 22:23:53 -040028 elif re.match('aarch64_ilp32$', a): return 'arm64'
29 elif re.match('aarch64_be_ilp32$', a): return 'arm64'
Patrick Williamsc0f7c042017-02-23 20:41:17 -060030 elif re.match('mips(isa|)(32|64|)(r6|)(el|)$', a): return 'mips'
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031 elif re.match('p(pc|owerpc)(|64)', a): return 'powerpc'
32 elif re.match('sh(3|4)$', a): return 'sh'
33 elif re.match('bfin', a): return 'blackfin'
34 elif re.match('microblazee[bl]', a): return 'microblaze'
35 elif a in valid_archs: return a
36 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050037 if not d.getVar("TARGET_OS").startswith("linux"):
38 return a
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039 bb.error("cannot map '%s' to a linux kernel architecture" % a)
40
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041export ARCH = "${@map_kernel_arch(d.getVar('TARGET_ARCH'), d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042
43def map_uboot_arch(a, d):
44 import re
45
46 if re.match('p(pc|owerpc)(|64)', a): return 'ppc'
47 elif re.match('i.86$', a): return 'x86'
48 return a
49
Brad Bishop6e60e8b2018-02-01 10:27:11 -050050export UBOOT_ARCH = "${@map_uboot_arch(d.getVar('ARCH'), d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051
52# Set TARGET_??_KERNEL_ARCH in the machine .conf to set architecture
53# specific options necessary for building the kernel and modules.
54TARGET_CC_KERNEL_ARCH ?= ""
55HOST_CC_KERNEL_ARCH ?= "${TARGET_CC_KERNEL_ARCH}"
56TARGET_LD_KERNEL_ARCH ?= ""
57HOST_LD_KERNEL_ARCH ?= "${TARGET_LD_KERNEL_ARCH}"
58TARGET_AR_KERNEL_ARCH ?= ""
59HOST_AR_KERNEL_ARCH ?= "${TARGET_AR_KERNEL_ARCH}"
60
61KERNEL_CC = "${CCACHE}${HOST_PREFIX}gcc ${HOST_CC_KERNEL_ARCH} -fuse-ld=bfd"
62KERNEL_LD = "${CCACHE}${HOST_PREFIX}ld.bfd ${HOST_LD_KERNEL_ARCH}"
63KERNEL_AR = "${CCACHE}${HOST_PREFIX}ar ${HOST_AR_KERNEL_ARCH}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050064TOOLCHAIN = "gcc"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065