blob: 6e350552f0073921bd105d2c9451ee327305a9c6 [file] [log] [blame]
Brad Bishope36358c2016-06-08 22:03:59 -04001# Common code for systemd based services.
2#
3# Prior to inheriting this class, recipes can define services like this:
4#
5# SYSTEMD_SERVICE_${PN} = "foo.service bar.socket baz@.service"
6#
7# and these files will be added to the main package if they exist.
8#
9# Alternatively this class can just be inherited and
Brad Bishop62d676a2016-07-11 00:42:58 -040010# ${PN}.service will be added to the main package.
Brad Bishop687146f2016-07-11 13:05:26 -040011#
12# Other variables:
13# INHIBIT_SYSTEMD_RESTART_POLICY_${unit}
14# Inhibit the warning that is displayed if a service unit without a
15# restart policy is detected.
Brad Bishop51528fe2016-07-14 19:34:06 -040016#
Brad Bishop5e329ba2016-08-17 12:08:16 -040017# SYSTEMD_SUBSTITUTIONS_${path-relative-to-system_unitdir}
18# Variables in this list will be substituted in the specified
Brad Bishop51528fe2016-07-14 19:34:06 -040019# file during install (if bitbake finds python {format} strings
Brad Bishop5e329ba2016-08-17 12:08:16 -040020# in the file itself). List entries take the form:
Brad Bishop51528fe2016-07-14 19:34:06 -040021# VAR:VALUE
22# where {VAR} is the format string bitbake should look for in the
Brad Bishop5e329ba2016-08-17 12:08:16 -040023# file and VALUE is the value to substitute.
Brad Bishopf815b2e2016-07-14 19:50:19 -040024#
Brad Bishop58700d12016-08-15 22:35:58 -040025# SYSTEMD_USER_${PN}.service = "foo"
26# SYSTEMD_USER_${unit}.service = "foo"
27# The user for the unit/package.
Brad Bishopafb2e1b2016-08-08 09:29:20 -040028#
29# SYSTEMD_ENVIRONMENT_FILE_${PN} = "foo"
30# One or more environment files to be installed.
Brad Bishop0161aff2016-08-17 14:46:41 -040031#
32# SYSTEMD_LINK_${PN} = "tgt:name"
33# A specification for installing arbitrary links in
34# the ${systemd_system_unitdir} namespace, where:
35# tgt: the link target
36# name: the link name, relative to ${systemd_system_unitdir}
Brad Bishop51528fe2016-07-14 19:34:06 -040037
Brad Bishop9dc56712016-07-07 15:56:02 -040038
39inherit obmc-phosphor-utils
Brad Bishop93fb5352015-09-09 03:59:20 +000040inherit systemd
Brad Bishopf815b2e2016-07-14 19:50:19 -040041inherit useradd
Brad Bishop93fb5352015-09-09 03:59:20 +000042
Brad Bishop9dc56712016-07-07 15:56:02 -040043_INSTALL_SD_UNITS=""
Brad Bishop51528fe2016-07-14 19:34:06 -040044SYSTEMD_DEFAULT_TARGET ?= "obmc-standby.target"
Brad Bishopafb2e1b2016-08-08 09:29:20 -040045envfiledir ?= "${sysconfdir}/default"
Brad Bishop9dc56712016-07-07 15:56:02 -040046
Brad Bishopf815b2e2016-07-14 19:50:19 -040047# Big ugly hack to prevent useradd.bbclass post-parse sanity checker failure.
48# If there are users to be added, we'll add them in our post-parse.
49# If not...there don't seem to be any ill effects...
50USERADD_PACKAGES ?= " "
51USERADD_PARAM_${PN} ?= ";"
52
Brad Bishope36358c2016-06-08 22:03:59 -040053
Brad Bishop18645292016-08-16 08:18:07 -040054def SystemdUnit(unit):
55 class Unit(object):
56 def __init__(self, unit):
57 self.unit = unit
Brad Bishop687146f2016-07-11 13:05:26 -040058
Brad Bishop18645292016-08-16 08:18:07 -040059 def __getattr__(self, item):
60 if item is 'name':
61 return self.unit
62 if item is 'is_activated':
63 return self.unit.startswith('dbus-')
64 if item is 'is_template':
65 return '@.' in self.unit
66 if item is 'is_instance':
67 return '@' in self.unit and not self.is_template
68 if item in ['is_service', 'is_target']:
69 return self.unit.split('.')[-1] == item
70 if item is 'base':
71 cls = self.unit.split('.')[-1]
72 base = self.unit.replace('dbus-', '')
73 base = base.replace('.%s' % cls, '')
74 if self.is_instance:
75 base = base.rstrip('@%s' % self.instance)
76 if self.is_template:
77 base = base.rstrip('@')
78 return base
79 if item is 'instance' and self.is_instance:
80 inst = self.unit.rsplit('@')[-1]
81 return inst.rsplit('.')[0]
82 if item is 'template' and self.is_instance:
83 cls = self.unit.split('.')[-1]
84 return '%s@.%s' % (self.base, cls)
85 if item is 'template' and self.is_template:
86 return '.'.join(self.base.split('@')[:-1])
Brad Bishop687146f2016-07-11 13:05:26 -040087
Brad Bishop18645292016-08-16 08:18:07 -040088 raise AttributeError(item)
89 return Unit(unit)
Brad Bishop687146f2016-07-11 13:05:26 -040090
91
92def systemd_parse_unit(d, path):
93 import ConfigParser
94 parser = ConfigParser.SafeConfigParser()
95 parser.optionxform = str
96 parser.read('%s' % path)
97 return parser
98
99
Brad Bishope36358c2016-06-08 22:03:59 -0400100python() {
Brad Bishop687146f2016-07-11 13:05:26 -0400101 def check_sd_unit(d, unit):
Brad Bishop9dc56712016-07-07 15:56:02 -0400102 searchpaths = d.getVar('FILESPATH', True)
Brad Bishop18645292016-08-16 08:18:07 -0400103 path = bb.utils.which(searchpaths, '%s' % unit.name)
Brad Bishop9dc56712016-07-07 15:56:02 -0400104 if not os.path.isfile(path):
Brad Bishop18645292016-08-16 08:18:07 -0400105 bb.fatal('Did not find unit file "%s"' % unit.name)
Brad Bishop687146f2016-07-11 13:05:26 -0400106
107 parser = systemd_parse_unit(d, path)
108 inhibit = listvar_to_list(d, 'INHIBIT_SYSTEMD_RESTART_POLICY_WARNING')
Brad Bishop18645292016-08-16 08:18:07 -0400109 if unit.is_service and \
110 not unit.is_template and \
111 unit.name not in inhibit and \
Brad Bishop687146f2016-07-11 13:05:26 -0400112 not parser.has_option('Service', 'Restart'):
113 bb.warn('Systemd unit \'%s\' does not '
Brad Bishop18645292016-08-16 08:18:07 -0400114 'have a restart policy defined.' % unit.name)
Brad Bishop687146f2016-07-11 13:05:26 -0400115
116
Brad Bishop522234c2016-08-17 15:42:31 -0400117 def add_default_subs(d, file):
118 set_append(d, '_MAKE_SUBS', '%s' % file)
Brad Bishop687146f2016-07-11 13:05:26 -0400119
Brad Bishop51528fe2016-07-14 19:34:06 -0400120 for x in [
121 'base_bindir',
122 'bindir',
123 'sbindir',
Brad Bishopafb2e1b2016-08-08 09:29:20 -0400124 'envfiledir',
Brad Bishop51528fe2016-07-14 19:34:06 -0400125 'SYSTEMD_DEFAULT_TARGET' ]:
Brad Bishop522234c2016-08-17 15:42:31 -0400126 set_append(d, 'SYSTEMD_SUBSTITUTIONS_%s' % file,
Brad Bishop51528fe2016-07-14 19:34:06 -0400127 '%s:%s' % (x, d.getVar(x, True)))
128
Brad Bishopf815b2e2016-07-14 19:50:19 -0400129
Brad Bishop522234c2016-08-17 15:42:31 -0400130 def add_sd_unit(d, unit, pkg):
Brad Bishop18645292016-08-16 08:18:07 -0400131 name = unit.name
Brad Bishop522234c2016-08-17 15:42:31 -0400132 unit_dir = d.getVar('systemd_system_unitdir', True)
133 set_append(d, 'SRC_URI', 'file://%s' % name)
134 set_append(d, 'FILES_%s' % pkg, '%s/%s' % (unit_dir, name))
135 set_append(d, '_INSTALL_SD_UNITS', name)
136 add_default_subs(d, name)
137
138
139 def add_sd_user(d, file, pkg):
Brad Bishopf815b2e2016-07-14 19:50:19 -0400140 opts = [
141 '--system',
142 '--home',
143 '/',
144 '--no-create-home',
145 '--shell /sbin/nologin',
146 '--user-group']
147
Brad Bishop522234c2016-08-17 15:42:31 -0400148 var = 'SYSTEMD_USER_%s' % file
Brad Bishop58700d12016-08-15 22:35:58 -0400149 user = listvar_to_list(d, var)
150 if len(user) is 0:
151 var = 'SYSTEMD_USER_%s' % pkg
152 user = listvar_to_list(d, var)
153 if len(user) is not 0:
154 if len(user) is not 1:
155 bb.fatal('Too many users assigned to %s: \'%s\'' % (var, ' '.join(user)))
156
157 user = user[0]
Brad Bishop522234c2016-08-17 15:42:31 -0400158 set_append(d, 'SYSTEMD_SUBSTITUTIONS_%s' % file,
Brad Bishop58700d12016-08-15 22:35:58 -0400159 'USER:%s' % user)
160 if user not in d.getVar('USERADD_PARAM_%s' % pkg, True):
161 set_append(
162 d,
163 'USERADD_PARAM_%s' % pkg,
164 '%s' % (' '.join(opts + [user])),
165 ';')
Brad Bishopf815b2e2016-07-14 19:50:19 -0400166 if pkg not in d.getVar('USERADD_PACKAGES', True):
167 set_append(d, 'USERADD_PACKAGES', pkg)
168
Brad Bishop9dc56712016-07-07 15:56:02 -0400169
Brad Bishopafb2e1b2016-08-08 09:29:20 -0400170 def add_env_file(d, name, pkg):
171 set_append(d, 'SRC_URI', 'file://%s' % name)
172 set_append(d, 'FILES_%s' % pkg, '%s/%s' \
173 % (d.getVar('envfiledir', True), name))
174 set_append(d, '_INSTALL_ENV_FILES', name)
175
176
Brad Bishop0161aff2016-08-17 14:46:41 -0400177 def install_link(d, spec, pkg):
178 tgt, dest = spec.split(':')
179
180 set_append(d, 'FILES_%s' % pkg, '%s/%s' \
181 % (d.getVar('systemd_system_unitdir', True), dest))
182 set_append(d, '_INSTALL_LINKS', spec)
183
184
Brad Bishop62d676a2016-07-11 00:42:58 -0400185 pn = d.getVar('PN', True)
Brad Bishop9dc56712016-07-07 15:56:02 -0400186 if d.getVar('SYSTEMD_SERVICE_%s' % pn, True) is None:
187 d.setVar('SYSTEMD_SERVICE_%s' % pn, '%s.service' % pn)
Brad Bishope36358c2016-06-08 22:03:59 -0400188
Brad Bishop9dc56712016-07-07 15:56:02 -0400189 for pkg in listvar_to_list(d, 'SYSTEMD_PACKAGES'):
Brad Bishop18645292016-08-16 08:18:07 -0400190 svc = listvar_to_list(d, 'SYSTEMD_SERVICE_%s' % pkg)
191 svc = [SystemdUnit(x) for x in svc]
192 tmpl = [x.template for x in svc if x.is_instance]
193 tmpl = list(set(tmpl))
194 tmpl = [SystemdUnit(x) for x in tmpl]
195 svc = [x for x in svc if not x.is_instance]
196
197 for unit in tmpl + svc:
Brad Bishop687146f2016-07-11 13:05:26 -0400198 check_sd_unit(d, unit)
Brad Bishop9dc56712016-07-07 15:56:02 -0400199 add_sd_unit(d, unit, pkg)
Brad Bishop522234c2016-08-17 15:42:31 -0400200 add_sd_user(d, unit.name, pkg)
Brad Bishopafb2e1b2016-08-08 09:29:20 -0400201 for name in listvar_to_list(d, 'SYSTEMD_ENVIRONMENT_FILE_%s' % pkg):
202 add_env_file(d, name, pkg)
Brad Bishop0161aff2016-08-17 14:46:41 -0400203 for spec in listvar_to_list(d, 'SYSTEMD_LINK_%s' % pkg):
204 install_link(d, spec, pkg)
Brad Bishope36358c2016-06-08 22:03:59 -0400205}
Brad Bishop93fb5352015-09-09 03:59:20 +0000206
Brad Bishop9dc56712016-07-07 15:56:02 -0400207
Brad Bishop51528fe2016-07-14 19:34:06 -0400208python systemd_do_postinst() {
Brad Bishop522234c2016-08-17 15:42:31 -0400209 def make_subs(d):
210 for f in listvar_to_list(d, '_MAKE_SUBS'):
211 subs = dict([ x.split(':') for x in
212 listvar_to_list(d, 'SYSTEMD_SUBSTITUTIONS_%s' % f)])
213 if not subs:
214 continue
Brad Bishop51528fe2016-07-14 19:34:06 -0400215
Brad Bishop522234c2016-08-17 15:42:31 -0400216 path = d.getVar('D', True)
217 path += d.getVar('systemd_system_unitdir', True)
218 path += '/%s' % f
219 with open(path, 'r') as fd:
220 content = fd.read()
221 with open(path, 'w+') as fd:
222 try:
223 fd.write(content.format(**subs))
224 except KeyError as e:
225 bb.fatal('No substitution found for %s in '
226 'file \'%s\'' % (e, f))
227
228
Brad Bishopafb2e1b2016-08-08 09:29:20 -0400229 def install_envs(d):
230 install_dir = d.getVar('D', True)
231 install_dir += d.getVar('envfiledir', True)
232 searchpaths = d.getVar('FILESPATH', True)
233
234 for f in listvar_to_list(d, '_INSTALL_ENV_FILES'):
235 src = bb.utils.which(searchpaths, f)
236 if not os.path.isfile(src):
237 bb.fatal('Did not find SYSTEMD_ENVIRONMENT_FILE:'
238 '\'%s\'' % src)
239
240 dest = os.path.join(install_dir, f)
241 parent = os.path.dirname(dest)
242 if not os.path.exists(parent):
243 os.makedirs(parent)
244
245 with open(src, 'r') as fd:
246 content = fd.read()
247 with open(dest, 'w+') as fd:
248 fd.write(content)
249
250
Brad Bishop0161aff2016-08-17 14:46:41 -0400251 def install_links(d):
252 install_dir = d.getVar('D', True)
253 install_dir += d.getVar('systemd_system_unitdir', True)
254
255 for spec in listvar_to_list(d, '_INSTALL_LINKS'):
256 tgt, dest = spec.split(':')
257 dest = os.path.join(install_dir, dest)
258 parent = os.path.dirname(dest)
259 if not os.path.exists(parent):
260 os.makedirs(parent)
261 os.symlink(tgt, dest)
262
263
264 install_links(d)
Brad Bishopafb2e1b2016-08-08 09:29:20 -0400265 install_envs(d)
Brad Bishop522234c2016-08-17 15:42:31 -0400266 make_subs(d)
Brad Bishop51528fe2016-07-14 19:34:06 -0400267}
268
269
Brad Bishop93fb5352015-09-09 03:59:20 +0000270do_install_append() {
Brad Bishope36358c2016-06-08 22:03:59 -0400271 # install systemd service/socket/template files
Brad Bishop9dc56712016-07-07 15:56:02 -0400272 [ -z "${_INSTALL_SD_UNITS}" ] || \
Brad Bishope36358c2016-06-08 22:03:59 -0400273 install -d ${D}${systemd_system_unitdir}
Brad Bishop9dc56712016-07-07 15:56:02 -0400274 for s in ${_INSTALL_SD_UNITS}; do
275 install -m 0644 ${WORKDIR}/$s \
276 ${D}${systemd_system_unitdir}/$s
Brad Bishope36358c2016-06-08 22:03:59 -0400277 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
278 -e 's,@BINDIR@,${bindir},g' \
279 -e 's,@SBINDIR@,${sbindir},g' \
280 ${D}${systemd_system_unitdir}/$s
281 done
Brad Bishop93fb5352015-09-09 03:59:20 +0000282}
Brad Bishop51528fe2016-07-14 19:34:06 -0400283
284
285do_install[postfuncs] += "systemd_do_postinst"