blob: ee522af08e6a729bb53ef00718a34e9fbb9a68bb [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Test vectors for the cryptography package."
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
6 file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
7 file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b"
8
9# NOTE: Make sure to keep this recipe at the same version as python3-cryptography
10# Upgrade both recipes at the same time
11
Patrick Williams39653562024-03-01 08:54:02 -060012SRC_URI[sha256sum] = "505cd5e3b0cb32da1526f07042b7fc38a4b6c356710cb73d2b5f76b037a38ed1"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060013
14PYPI_PACKAGE = "cryptography_vectors"
15
16inherit pypi python_setuptools_build_meta
17
18DEPENDS += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-cryptography \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060020"
21
22do_install:append () {
23 # Remove the sha256 checksum lines for pycache files
24 sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i
25}
26
27BBCLASSEXTEND = "native nativesdk"
28
29UPSTREAM_CHECK_REGEX = ""
Patrick Williamsda295312023-12-05 16:48:56 -060030
31RECIPE_NO_UPDATE_REASON = "Must be updated in sync with python3-cryptography."