blob: 9429705b1f8caf5d8c8bf38201217373bc350595 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Library and tool for installing Python wheels"
2DESCRIPTION = "A low-level library for installing a Python package from a wheel distribution."
3HOMEPAGE = "https://installer.readthedocs.io/"
4BUGTRACKER = "https://github.com/pypa/installer/issues"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=5038641aec7a77451e31da828ebfae00"
8
9SRC_URI += "file://interpreter.patch"
10
Patrick Williams8e7b46e2023-05-01 14:19:06 -050011SRC_URI[sha256sum] = "a26d3e3116289bb08216e0d0f7d925fcef0b0194eedfa0c944bcaaa106c4b631"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13inherit pypi python_flit_core
14
15# Bootstrap the native build
Andrew Geisslerc5535c92023-01-27 16:10:19 -060016DEPENDS:remove:class-native = "python3-build-native python3-installer-native"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
Patrick Williamse760df82023-05-26 11:10:49 -050018RDEPENDS:${PN} += " \
19 python3-compile \
20 python3-compression \
21 python3-netclient \
22"
23
Andrew Geissler517393d2023-01-13 08:55:19 -060024INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"
25
26do_compile:class-native () {
27 python_flit_core_do_manual_build
28}
29
30do_install:prepend:class-native() {
31 export PYTHONPATH="${S}/src"
32}
33
34BBCLASSEXTEND = "native nativesdk"