blob: 07dd548475de466690029cea2bc7aec77388a87b [file] [log] [blame]
Brad Bishopf61a81a2019-02-04 14:28:33 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " file://pam.d/common-password \
4 file://pam.d/common-account \
5 file://pam.d/common-auth \
Richard Marian Thomaiyar2b597052019-11-02 21:24:29 +05306 file://pam.d/common-session \
Brad Bishopf61a81a2019-02-04 14:28:33 -05007 "
8
9RDEPENDS_${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
10 ${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \
11 ${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \
Richard Marian Thomaiyar02292602020-01-28 15:02:37 +053012 ${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \
Brad Bishopf61a81a2019-02-04 14:28:33 -050013 "
14
Matt Spinler31ab8e72018-10-16 11:32:13 -050015do_install_append() {
16 # The libpam recipe will always add a pam_systemd.so line to
17 # common-session if systemd is enabled; however systemd only
18 # builds pam_systemd.so if logind is enabled, and we disable
19 # that package. So, remove the pam_systemd.so line here.
20 sed -i '/pam_systemd.so/d' ${D}${sysconfdir}/pam.d/common-session
21}