Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 1 | SUMMARY = "Python bindings for the DBus inter-process communication system" |
| 2 | SECTION = "devel/python" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=97f58951300aa52a9f9e3a62bd5c846c" |
| 6 | DEPENDS = "expat dbus glib-2.0 virtual/libintl" |
| 7 | |
| 8 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz" |
| 9 | |
| 10 | SRC_URI[sha256sum] = "ad67819308618b5069537be237f8e68ca1c7fcc95ee4a121fe6845b1418248f8" |
| 11 | |
| 12 | S = "${WORKDIR}/dbus-python-${PV}" |
| 13 | |
| 14 | inherit setuptools3-base meson pkgconfig |
| 15 | |
| 16 | # requires dbus-run-session |
| 17 | EXTRA_OEMESON += "-Dtests=false" |
| 18 | |
| 19 | RDEPENDS:${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml" |
| 20 | |
| 21 | FILES:${PN}-dev += "${libdir}/pkgconfig" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |