blob: 73a393051ab4da08b66187138995b0d67f962c3e [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Python GObject bindings"
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject"
3DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more."
4SECTION = "devel/python"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-only"
Andrew Geisslereff27472021-10-29 15:35:00 -05006LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
7
Andrew Geissler595f6302022-01-24 19:11:47 +00008GIR_MESON_OPTION = ""
9
Andrew Geissler5082cc72023-09-11 08:41:39 -040010inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even
Andrew Geisslereff27472021-10-29 15:35:00 -050011
Andrew Geissler5082cc72023-09-11 08:41:39 -040012python() {
13 if d.getVar('CLASSOVERRIDE') == "class-target" and not bb.utils.to_boolean(d.getVar("GI_DATA_ENABLED")):
14 raise bb.parse.SkipRecipe("GI not available")
15}
Patrick Williamse760df82023-05-26 11:10:49 -050016
17DEPENDS += "python3 glib-2.0"
Andrew Geisslereff27472021-10-29 15:35:00 -050018
Andrew Geisslereff27472021-10-29 15:35:00 -050019SRCNAME="pygobject"
20
Andrew Geissler220dafd2023-10-04 10:18:08 -050021SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz"
22SRC_URI[sha256sum] = "426008b2dad548c9af1c7b03b59df0440fde5c33f38fb5406b103a43d653cafc"
Andrew Geisslereff27472021-10-29 15:35:00 -050023
24S = "${WORKDIR}/${SRCNAME}-${PV}"
25
26PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
27
Patrick Williamse760df82023-05-26 11:10:49 -050028RDEPENDS:${PN} += " \
29 python3-io \
30 python3-pkgutil \
31"
Andrew Geisslereff27472021-10-29 15:35:00 -050032
33# python3-pycairo is checked on configuration -> DEPENDS
34# we don't link against python3-pycairo -> RDEPENDS
35PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo"
Andrew Geissler220dafd2023-10-04 10:18:08 -050036PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,"
Andrew Geisslereff27472021-10-29 15:35:00 -050037
38BBCLASSEXTEND = "native"
39PACKAGECONFIG:class-native = ""