blob: eab0c5c6c5017e1e0d271353963c7f7b2ca7d9f1 [file] [log] [blame]
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
Adriana Kobylak9ede23c2017-02-09 13:43:22 -060010inherit phosphor-dbus-interfaces
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050011inherit phosphor-logging
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050012
13DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
14
15DEPENDS += "autoconf-archive-native"
16DEPENDS += "systemd"
17DEPENDS += "python-mako-native"
18DEPENDS += "python-pyyaml-native"
Patrick Williams845123d2016-12-09 08:56:38 -060019DEPENDS += "sdbusplus sdbusplus-native"
Adriana Kobylak385287c2017-02-09 15:06:41 -060020DEPENDS += "phosphor-dbus-interfaces"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050021DEPENDS += "virtual/phosphor-logging-callouts"
Adriana Kobylak385287c2017-02-09 15:06:41 -060022RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050023PROVIDES += "virtual/obmc-logging-mgmt"
24RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
25
Michael Tritz026fbaf2017-03-13 14:54:24 -050026PACKAGE_BEFORE_PN = "${PN}-test"
27FILES_${PN}-test = "${bindir}/*-test"
28
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050029SRC_URI += "git://github.com/openbmc/phosphor-logging"
Michael Tritz026fbaf2017-03-13 14:54:24 -050030SRCREV = "98a1834c461836302bd3c0bc66cc4f6e1e55cd57"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050031
32S = "${WORKDIR}/git"
33
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050034EXTRA_OECONF = " \
35 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
36 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
37 "
38
39TARGET_CXXFLAGS += "-DPROCESS_META"