blob: 8b09ab0d07f3fec24631e2415e6041c174305a99 [file] [log] [blame]
Patrick Williams8dd68482022-10-04 07:57:18 -05001SUMMARY = "External system Cortex-M3 Firmware"
2DESCRIPTION = "Firmware to be loaded and run in External System Harness in\
3 support to the main application CPU."
4HOMEPAGE = "https://git.linaro.org/landing-teams/working/arm/external-system.git"
5DEPENDS = "gcc-arm-none-eabi-native"
6INHIBIT_DEFAULT_DEPS="1"
7LICENSE = "BSD-3-Clause & Apache-2.0"
8LIC_FILES_CHKSUM = "file://license.md;md5=e44b2531cd6ffe9dece394dbe988d9a0 \
9 file://cmsis/LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
10
Andrew Geissler9347dd42023-03-03 12:38:41 -060011SRC_URI = "gitsm://git.gitlab.arm.com/arm-reference-solutions/corstone1000/external_system/rtx.git;protocol=https;branch=master \
12 file://race.patch"
Patrick Williams8dd68482022-10-04 07:57:18 -050013SRCREV = "8c9dca74b104ff6c9722fb0738ba93dd3719c080"
14PV .= "+git${SRCPV}"
15
16COMPATIBLE_MACHINE = "(corstone1000)"
17
18# PRODUCT is passed to the Makefile to specify the platform to be used.
19PRODUCT = "corstone-1000"
20
21S = "${WORKDIR}/git"
22B = "${WORKDIR}/build"
23
Patrick Williams520786c2023-06-25 16:20:36 -050024# remove once arm-none-eabi-gcc updates to 13 or newer like poky
25DEBUG_PREFIX_MAP:remove = "-fcanon-prefix-map"
26
Patrick Williams8dd68482022-10-04 07:57:18 -050027LDFLAGS[unexport] = "1"
28
29do_compile() {
30 oe_runmake -C ${S} V=y \
31 BUILD_PATH=${B} \
32 PRODUCT=${PRODUCT} \
33 CROSS_COMPILE=arm-none-eabi- \
34 all
35}
36
37do_compile[cleandirs] = "${B}"
38
39do_install() {
40 install -D -p -m 0644 ${B}/product/${PRODUCT}/firmware/release/bin/firmware.bin ${D}/firmware/es_flashfw.bin
41}
42
43FILES:${PN} = "/firmware"
44SYSROOT_DIRS += "/firmware"
45
46inherit deploy
47
48do_deploy() {
49 cp -rf ${D}/firmware/* ${DEPLOYDIR}/
50}
51addtask deploy after do_install