Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Open source iec61850 implementation" |
| 2 | DESCRIPTION = "IEC 61850 is an international standard for \ |
| 3 | communication systems in Substation Automation Systems \ |
| 4 | (SAS) and management of Decentralized Energy Resources \ |
| 5 | (DER). It is seen as one of the communication standards \ |
| 6 | of the emerging Smart Grid. \ |
| 7 | The project libIEC61850 provides a server and client \ |
| 8 | library for the IEC 61850/MMS, IEC 61850/GOOSE and IEC \ |
| 9 | 61850-9-2/Sampled Values communication protocols \ |
| 10 | written in C. It is available under the GPLv3 license." |
| 11 | HOMEPAGE = "http://libiec61850.com" |
| 12 | SECTION = "console/network" |
| 13 | LICENSE = "GPL-3.0-only" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 15 | DEPENDS = "swig-native python3" |
| 16 | SRCREV = "210cf30897631fe2006ac50483caf8fd616622a2" |
| 17 | |
| 18 | SRC_URI = "git://github.com/mz-automation/${BPN}.git;branch=v1.5;protocol=https \ |
| 19 | file://0001-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch \ |
| 20 | file://0001-pyiec61850-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallD.patch \ |
| 21 | " |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit cmake pkgconfig python3-dir python3native siteinfo |
| 26 | |
| 27 | EXTRA_OECMAKE = " \ |
| 28 | -DBUILD_EXAMPLES=OFF \ |
| 29 | -DBUILD_PYTHON_BINDINGS=ON \ |
| 30 | " |
| 31 | |
| 32 | RDEPENDS:${PN}-python = " python3-core " |
| 33 | RDEPENDS:${PN} = " python3-core " |
| 34 | |
| 35 | FILES:${PN} += " \ |
| 36 | ${libdir}/${PYTHON_DIR}/site-packages/iec61850.py \ |
| 37 | ${libdir}/${PYTHON_DIR}/site-packages/_iec61850.so \ |
| 38 | " |