blob: 34f3639e5320009f3799ecf3889a2485b8394da6 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A collection of ASN.1-based protocols modules."
2DESCRIPTION = "A collection of ASN.1 modules expressed in form of pyasn1\
3 classes. Includes protocols PDUs definition (SNMP, LDAP etc.) and various\
4 data structures (X.509, PKCS etc.)."
5HOMEPAGE = "https://github.com/etingof/pyasn1-modules"
6LICENSE = "BSD-2-Clause"
Andrew Geissler220dafd2023-10-04 10:18:08 -05007LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=190f79253908c986e6cacf380c3a5f6d"
Brad Bishop316dfdd2018-06-25 12:45:53 -04008
Patrick Williams03514f12024-04-05 07:04:11 -05009SRC_URI[sha256sum] = "831dbcea1b177b28c9baddf4c6d1013c24c3accd14a1873fffaa6a2e905f17b6"
Andrew Geissler220dafd2023-10-04 10:18:08 -050010
11PYPI_PACKAGE = "pyasn1_modules"
Brad Bishop316dfdd2018-06-25 12:45:53 -040012
Andrew Geisslerd221e032020-07-10 16:13:21 -050013inherit pypi ptest setuptools3
Brad Bishop316dfdd2018-06-25 12:45:53 -040014
Patrick Williams73bd93f2024-02-20 08:07:48 -060015RDEPENDS:${PN} = "python3-pyasn1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016
17BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
19SRC_URI += " \
20 file://run-ptest \
21"
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060024 python3-pytest \
25 python3-unittest-automake-output \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026"
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}/tests
30 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
31}