Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Python documentation generator" |
| 2 | HOMEPAGE = "http://sphinx-doc.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=de4349dda741c550eb8b20f6b92f38d7" |
| 6 | |
| 7 | PYPI_PACKAGE = "Sphinx" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "6caad9786055cb1fa22b4a365c1775816b876f91966481765d7d50e9f0dd35cc" |
| 10 | |
| 11 | inherit setuptools3 pypi |
| 12 | |
| 13 | |
| 14 | do_install:append () { |
| 15 | # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?) |
| 16 | rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex* |
| 17 | } |
| 18 | |
| 19 | RDEPENDS:${PN} = "\ |
| 20 | python3-packaging python3-docutils python3-requests \ |
| 21 | python3-imagesize python3-alabaster python3-jinja2 \ |
| 22 | python3-babel python3-pygments python3-snowballstemmer \ |
| 23 | python3-sphinxcontrib-applehelp python3-sphinxcontrib-devhelp \ |
| 24 | python3-sphinxcontrib-jsmath python3-sphinxcontrib-htmlhelp \ |
| 25 | python3-sphinxcontrib-serializinghtml python3-sphinxcontrib-qthelp \ |
| 26 | " |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |