blob: c57324d89c513725667a5dedd44cd6461a5382e9 [file] [log] [blame]
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05001SUMMARY = "New set of tools for working with SquashFS images"
2SECTION = "base"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-3.0-or-later & LGPL-3.0-or-later & MIT & BSD-2-Clause & Zlib"
Patrick Williams03907ee2022-05-01 06:28:52 -05004LIC_FILES_CHKSUM = "file://COPYING.md;md5=5789fb0572753ed69014cd90a445cd74 \
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05005 file://licenses/GPLv3.txt;md5=1ebbd3e34237af26da5dc08a4e440464 \
6 file://licenses/hash_table.txt;md5=874823605326caeaabaa95bfbd0f9fb0 \
7 file://licenses/LGPLv3.txt;md5=3000208d539ec061b899bce1d9ce9404 \
8 file://licenses/LZ4.txt;md5=ebc2ea4814a64de7708f1571904b32cc \
9 file://licenses/xxhash.txt;md5=f042a9be092bd6d7fe6f217d8d00f4ca \
10 file://licenses/xz.txt;md5=1c389b9610ccfdb25f7abaea6a0bb5a4 \
11 file://licenses/zlib.txt;md5=ae27c72096606131f760e5f59cf98b06 \
Patrick Williams03907ee2022-05-01 06:28:52 -050012 file://licenses/zstd.txt;md5=8df8137b630239cbdd4c0674124cb0c8 \
13 "
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050014
Patrick Williams03907ee2022-05-01 06:28:52 -050015SRCREV = "7667b84cc34707c28ca0db8d24f046ec34e8c25d"
Andrew Geissler595f6302022-01-24 19:11:47 +000016SRC_URI = "git://github.com/AgentD/squashfs-tools-ng.git;protocol=https;branch=master"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050017
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig
21
22PACKAGECONFIG ??= "gzip xz lzo lz4 zstd ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
23PACKAGECONFIG[gzip] = "--with-gzip,--without-gzip,zlib"
24PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz"
25PACKAGECONFIG[lzo] = "--with-lzo,--without-lzo,lzo"
26PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4"
27PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
28PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
29
30PACKAGES =+ "libsquashfs"
Patrick Williams213cb262021-08-07 19:21:33 -050031FILES:libsquashfs = "${libdir}/libsquashfs*${SOLIBS}"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050032
33BBCLASSEXTEND = "native nativesdk"