blob: a27968079ecb4001306fc932809e445e669b8ac5 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The GNU portability library"
2DESCRIPTION = "A collection of software subroutines which are designed to \
3be usable on many operating systems. The goal of the project \
4is to make it easy for free software authors to make their \
5software run on many operating systems. Since source is designed \
6to be copied from gnulib, it is not a library per-se, as much \
7as a collection of portable idioms to be used in other projects."
8
9HOMEPAGE = "http://www.gnu.org/software/gnulib/"
10SECTION = "devel"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "LGPL-2.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -040012
13LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5"
14SRCREV = "0d6e3307bbdb8df4d56043d5f373eeeffe4cbef3"
15
Patrick Williams03907ee2022-05-01 06:28:52 -050016SRC_URI = "git://git.savannah.gnu.org/git/gnulib.git;branch=master \
Brad Bishop19323692019-04-05 15:28:33 -040017"
18
19S = "${WORKDIR}/git"
20
Brad Bishop19323692019-04-05 15:28:33 -040021do_install () {
Patrick Williams03907ee2022-05-01 06:28:52 -050022 install -d ${D}/${datadir}/gnulib
23 cp --no-preserve=ownership --recursive ${S}/* ${D}/${datadir}/gnulib/
24 cp --no-preserve=ownership --recursive ${S}/.git ${D}/${datadir}/gnulib/
Brad Bishop19323692019-04-05 15:28:33 -040025}
26
27do_patch[noexec] = "1"
28do_configure[noexec] = "1"
29do_compile[noexec] = "1"
30do_package[noexec] = "1"
31do_packagedata[noexec] = "1"
32deltask package_write_ipk
33deltask package_write_deb
34deltask package_write_rpm
35deltask do_deploy_archives
36
37BBCLASSEXTEND = "native"