blob: cdbe4b4b257a07401babf54ea18c77a3cb9adc41 [file] [log] [blame]
Andrew Geissler3e34fba2021-03-05 15:21:55 -06001SUMMARY = "Pure python (i.e. no native extensions) access to Linux IO including I2C and SPI. Drop in replacement for smbus and spidev modules."
2HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PureIO"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=2a21fcca821a506d4c36f7bbecc0d009"
5
Andrew Geissler595f6302022-01-24 19:11:47 +00006SRC_URI = "git://github.com/adafruit/Adafruit_Python_PureIO.git;branch=main;protocol=https"
Patrick Williams03907ee2022-05-01 06:28:52 -05007SRCREV = "383b615ce9ff5bbefdf77652799f380016fda353"
Andrew Geissler3e34fba2021-03-05 15:21:55 -06008
9S = "${WORKDIR}/git"
10
11inherit setuptools3
12
13DEPENDS += "python3-setuptools-scm-native"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN} += " \
Andrew Geissler3e34fba2021-03-05 15:21:55 -060016 python3-core \
17 python3-ctypes \
18 python3-fcntl \
19"