blob: 45da416a7833fbf2c4b67e675c4edd1010f1975a [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301SUMMARY = "Command line utility to extend hash of arbitrary data into a TPMs PCR."
2HOMEPAGE = "https://github.com/flihp/pcr-extend"
3SECTION = "security/tpm"
Patrick Williams03907ee2022-05-01 06:28:52 -05004LICENSE = "GPL-2.0-only"
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05305LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "libtspi"
8
9PV = "0.1+git${SRCPV}"
10SRCREV = "c02ad8f628b3d99f6d4c087b402fe31a40ee6316"
11
Patrick Williams53961c22022-01-20 11:06:23 -060012SRC_URI = "git://github.com/flihp/pcr-extend.git;branch=master;protocol=https \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013 file://fix_openssl11_build.patch "
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053014
15inherit autotools
16
17S = "${WORKDIR}/git"
18
19do_compile() {
20 oe_runmake -C ${S}/src
21}
22
23do_install() {
24 install -d ${D}${bindir}
25 oe_runmake -C ${S}/src DESTDIR="${D}" install
26}