blob: 980c488640d89f5cebbd9f661fdf9c64ec49a19e [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "https://github.com/libexpat/libexpat"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
8
9VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
10
11SRC_URI = "https://github.com/libexpat/libexpat/releases/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
12 file://run-ptest \
13 "
14
15UPSTREAM_CHECK_URI = "https://github.com/libexpat/libexpat/releases/"
16
Patrick Williams03907ee2022-05-01 06:28:52 -050017SRC_URI[sha256sum] = "a247a7f6bbb21cf2ca81ea4cbb916bfb9717ca523631675f99b3d4a5678dcd16"
Andrew Geissler9aee5002022-03-30 16:27:02 +000018
19EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
20
21RDEPENDS:${PN}-ptest += "bash"
22
23inherit cmake lib_package ptest
24
25do_install_ptest:class-target() {
26 install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
27}
28
29BBCLASSEXTEND += "native nativesdk"
30
31CVE_PRODUCT = "expat libexpat"