blob: 2c554f863a90036ceeed5b64f51c4bcc03788461 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
9HOMEPAGE = "http://www.acpica.org/"
10SECTION = "console/tools"
11
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only"
Patrick Williams03907ee2022-05-01 06:28:52 -050013LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=41a76b4b1f816240f090cf010fefebf0"
Andrew Geissler595f6302022-01-24 19:11:47 +000014
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "m4-native flex-native bison-native"
18
19SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz"
Patrick Williams03907ee2022-05-01 06:28:52 -050020SRC_URI[sha256sum] = "acaff68b14f1e0804ebbfc4b97268a4ccbefcfa053b02ed9924f2b14d8a98e21"
Andrew Geissler595f6302022-01-24 19:11:47 +000021
22UPSTREAM_CHECK_URI = "https://acpica.org/downloads"
23
24S = "${WORKDIR}/acpica-unix-${PV}"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE:${PN} = "acpixtract acpidump"
30
31EXTRA_OEMAKE = "CC='${CC}' \
32 OPT_CFLAGS=-Wall \
33 DESTDIR=${D} \
34 PREFIX=${prefix} \
35 INSTALLDIR=${bindir} \
36 INSTALLFLAGS= \
37 YACC=bison \
38 YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \
39 "
40
41do_install() {
42 oe_runmake install
43}
44
45# iasl*.bb is a subset of this recipe, so RREPLACE it
46PROVIDES = "iasl"
47RPROVIDES:${PN} += "iasl"
48RREPLACES:${PN} += "iasl"
49RCONFLICTS:${PN} += "iasl"
50
51BBCLASSEXTEND = "native"