blob: ada35dbc4c271500c27b346be33ad61b67ea3e49 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
Patrick Williams03907ee2022-05-01 06:28:52 -05008SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \
9 file://0001-Makefile-quote-CC.patch \
10 "
11SRCREV = "ec7f6c4731a54f0e515bef7f7e84ef9e9b8125a2"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012S = "${WORKDIR}/git"
13
14DEPENDS = "coreutils-native"
15
16PROVIDES = "stress"
17RPROVIDES:${PN} = "stress"
18RREPLACES:${PN} = "stress"
19RCONFLICTS:${PN} = "stress"
20
21inherit bash-completion
22
Patrick Williams03907ee2022-05-01 06:28:52 -050023do_configure:prepend() {
24 mkdir -p configs
25 touch configs/HAVE_APPARMOR
26}
27
Andrew Geissler9aee5002022-03-30 16:27:02 +000028do_install() {
29 oe_runmake DESTDIR=${D} install
30 ln -s stress-ng ${D}${bindir}/stress
31}