blob: 96d56c2ea4e06bc159bba69790950db5541b5de5 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Enchant Spell checker API Library"
2DESCRIPTION = "A library (and command-line program) that wraps a number of \
3different spelling libraries and programs with a consistent interface."
4SECTION = "libs"
5HOMEPAGE = "https://abiword.github.io/enchant/"
6BUGTRACKER = "https://github.com/AbiWord/enchant/issues/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "LGPL-2.1-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
9
10DEPENDS = "glib-2.0"
11
12inherit autotools pkgconfig
13
14SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz"
Patrick Williams03907ee2022-05-01 06:28:52 -050015SRC_URI[sha256sum] = "3da12103f11cf49c3cf2fd2ce3017575c5321a489e5b9bfa81dd91ec413f3891"
Andrew Geissler595f6302022-01-24 19:11:47 +000016
17UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases"
18
19S = "${WORKDIR}/enchant-${PV}"
20
21EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2"
22
23PACKAGECONFIG ??= "aspell"
24PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
25PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
26
27FILES:${PN} += " \
28 ${datadir}/enchant-2 \
29 ${libdir}/enchant-2 \
30"
31FILES:${PN}-staticdev += "${libdir}/enchant-2/*.a"