blob: 6e16e886b9d8d75e7c9f462e274bc0ec1bf8c290 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001require libcap-ng.inc
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08002
Brad Bishop15ae2502019-06-18 21:44:24 -04003inherit lib_package autotools
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
Brad Bishop15ae2502019-06-18 21:44:24 -04005EXTRA_OECONF += "--without-python --without-python3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006
Brad Bishop15ae2502019-06-18 21:44:24 -04007BBCLASSEXTEND = "native nativesdk"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Patrick Williams213cb262021-08-07 19:21:33 -05009do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 # Moving libcap-ng to base_libdir
11 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
12 mkdir -p ${D}/${base_libdir}/
13 mv -f ${D}${libdir}/libcap-ng.so.* ${D}${base_libdir}/
14 relpath=${@os.path.relpath("${base_libdir}", "${libdir}")}
15 ln -sf ${relpath}/libcap-ng.so.0.0.0 ${D}${libdir}/libcap-ng.so
16 fi
17}