blob: 8c2cadfe2b6a5b01d0858a7e4f0b46d3e8cdd994 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "There are two major versions of the PCRE library. The \
2newest version is PCRE2, which is a re-working of the original PCRE \
3library to provide an entirely new API. The original, very widely \
4deployed PCRE library's API and feature are stable, future releases \
5 will be for bugfixes only. All new future features will be to PCRE2, \
6not the original PCRE 8.x series."
7SUMMARY = "Perl Compatible Regular Expressions version 2"
8HOMEPAGE = "http://www.pcre.org"
9SECTION = "devel"
10LICENSE = "BSD-3-Clause"
Patrick Williams03907ee2022-05-01 06:28:52 -050011LIC_FILES_CHKSUM = "file://LICENCE;md5=41bfb977e4933c506588724ce69bf5d2"
Andrew Geissler595f6302022-01-24 19:11:47 +000012
13SRC_URI = "https://github.com/PhilipHazel/pcre2/releases/download/pcre2-${PV}/pcre2-${PV}.tar.bz2"
14
15UPSTREAM_CHECK_URI = "https://github.com/PhilipHazel/pcre2/releases"
16
Patrick Williams03907ee2022-05-01 06:28:52 -050017SRC_URI[sha256sum] = "14e4b83c4783933dc17e964318e6324f7cae1bc75d8f3c79bc6969f00c159d68"
Andrew Geissler595f6302022-01-24 19:11:47 +000018
19CVE_PRODUCT = "pcre2"
20
21S = "${WORKDIR}/pcre2-${PV}"
22
23PROVIDES += "pcre2"
24DEPENDS += "bzip2 zlib"
25
26BINCONFIG = "${bindir}/pcre2-config"
27
28inherit autotools binconfig-disabled
29
30EXTRA_OECONF = "\
31 --enable-newline-is-lf \
32 --with-link-size=2 \
33 --with-match-limit=10000000 \
34 --enable-pcre2-16 \
35 --enable-pcre2-32 \
36"
37CFLAGS += "-D_REENTRANT"
38CXXFLAGS:append:powerpc = " -lstdc++"
39
40PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
41
42SUMMARY:pcre2grep = "grep utility that uses perl 5 compatible regexes"
43SUMMARY:pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
44SUMMARY:pcre2test = "program for testing Perl-comatible regular expressions"
45SUMMARY:pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
46
47FILES:libpcre2-16 = "${libdir}/libpcre2-16.so.*"
48FILES:libpcre2-32 = "${libdir}/libpcre2-32.so.*"
49FILES:pcre2grep = "${bindir}/pcre2grep"
50FILES:pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
51FILES:pcre2test = "${bindir}/pcre2test"
52FILES:pcre2test-doc = "${mandir}/man1/pcre2test.1"
53
54BBCLASSEXTEND = "native nativesdk"