blob: 92148bd34977dd1a4c1e5421e8813099fe4fd845 [file] [log] [blame]
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +03001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
Konstantin Aladyshev040d3bc2023-01-17 12:48:39 +03002OBMC_CONSOLE_HOST_TTY:ethanolx = "ttyS0"
Brad Bishopc7d1cd92020-09-09 09:57:07 -04003
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +03004SRC_URI:remove = "file://${BPN}.conf"
Konstantin Aladyshev040d3bc2023-01-17 12:48:39 +03005SRC_URI:ethanolx += "file://server.ttyS0.conf"
Brad Bishopc7d1cd92020-09-09 09:57:07 -04006
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +03007do_install:append() {
Brad Bishopc7d1cd92020-09-09 09:57:07 -04008 # Remove upstream-provided configuration
9 rm -rf ${D}${sysconfdir}/${BPN}
10
11 # Install the server configuration
12 install -m 0755 -d ${D}${sysconfdir}/${BPN}
13 install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
14
15}