blob: 8cae08c9d7efd1f3dc56c36936128a869d5a2c12 [file] [log] [blame]
Brad Bishop0f547b12017-05-31 14:08:33 -04001SUMMARY = "Phosphor DBus Monitor"
2DESCRIPTION = "Phosphor DBus Monitor is a general purpose DBus application \
3that watches DBus traffic for events and takes actions based on those events."
4PR = "r1"
5
6HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor"
Andrew Geissler7f392352017-11-14 18:30:10 +000010SRCREV = "80e9b65fdf9b1172e02de606cc193a6723791828"
Brad Bishop0f547b12017-05-31 14:08:33 -040011
12inherit autotools \
13 pkgconfig \
14 pythonnative \
15 phosphor-dbus-monitor \
16 obmc-phosphor-systemd
17
Brad Bishop48628b42017-08-02 01:32:43 -040018PACKAGE_BEFORE_PN = "phosphor-msl-verify"
19SYSTEMD_PACKAGES = "${PN} phosphor-msl-verify"
20SYSTEMD_SERVICE_phosphor-msl-verify = "phosphor-msl-verify.service"
21
Brad Bishop0f547b12017-05-31 14:08:33 -040022DEPENDS += " \
23 ${PN}-config-native \
24 phosphor-logging \
25 autoconf-archive-native \
Brad Bishop04ff12c2018-01-26 21:48:20 -050026 sdbusplus-native \
Brad Bishop0f547b12017-05-31 14:08:33 -040027 gtest \
28 "
29RDEPENDS_${PN} += " \
30 sdbusplus \
31 phosphor-dbus-interfaces \
32 phosphor-logging \
33 "
34
Brad Bishop48628b42017-08-02 01:32:43 -040035RDEPENDS_phosphor-msl-verify += " \
36 sdbusplus \
37 phosphor-dbus-interfaces \
38 phosphor-logging \
39 "
40FILES_phosphor-msl-verify = "${sbindir}/phosphor-msl-verify"
41
Brad Bishop0f547b12017-05-31 14:08:33 -040042S = "${WORKDIR}/git"
43
44EXTRA_OECONF = " \
45 YAML_PATH=${STAGING_DIR_NATIVE}${config_dir} \
46 "