Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Tool to produce a statistics based on a diff" |
| 2 | DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \ |
| 3 | the insertions, deletions, and modifications per-file. It is useful for \ |
| 4 | reviewing large, complex patch files." |
| 5 | HOMEPAGE = "http://invisible-island.net/diffstat/" |
| 6 | SECTION = "devel" |
| 7 | LICENSE = "MIT" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=f605b1986cc3b808ec0e4fa9d0e0f2d9" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \ |
| 11 | file://run-ptest \ |
| 12 | file://avoid-check-user-break-cc.patch \ |
| 13 | file://0001-aclocal.m4-add-missing-header-defines.patch \ |
| 14 | " |
| 15 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "b8aee38d9d2e1d05926e6b55810a9d2c2dd407f24d6a267387563a4436e3f7fc" |
Andrew Geissler | 706d5aa | 2021-02-12 15:55:30 -0600 | [diff] [blame] | 17 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | inherit autotools gettext ptest |
| 19 | |
| 20 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 21 | |
| 22 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | cp -r ${S}/testing ${D}${PTEST_PATH} |
| 26 | } |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 27 | |
| 28 | BBCLASSEXTEND = "nativesdk" |