blob: 61b2ea5dc21f12191a551bcb9598ae308959e4f3 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "MIT"
Andrew Geissler706d5aa2021-02-12 15:55:30 -06008LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
11 file://run-ptest \
12 file://avoid-check-user-break-cc.patch \
13 file://0001-aclocal.m4-add-missing-header-defines.patch \
14 "
15
16SRC_URI[md5sum] = "b9272ec8af6257103261ec3622692991"
17SRC_URI[sha256sum] = "7eddd53401b99b90bac3f7ebf23dd583d7d99c6106e67a4f1161b7a20110dc6f"
18
Andrew Geissler706d5aa2021-02-12 15:55:30 -060019S = "${WORKDIR}/diffstat-${PV}"
20
Andrew Geissler82c905d2020-04-13 13:39:40 -050021inherit autotools gettext ptest
22
23EXTRA_AUTORECONF += "--exclude=aclocal"
24
25LDFLAGS += "${TOOLCHAIN_OPTIONS}"
26
27do_install_ptest() {
28 cp -r ${S}/testing ${D}${PTEST_PATH}
29}
Andrew Geissler6ce62a22020-11-30 19:58:47 -060030
31BBCLASSEXTEND = "nativesdk"