blob: 4e48365a71b7fb69426b0eaa879c1c1c445b35b6 [file] [log] [blame]
Andrew Geissler95ac1b82021-03-31 14:34:31 -05001SUMMARY = "Extremely fast non-cryptographic hash algorithm"
2DESCRIPTION = "xxHash is an extremely fast non-cryptographic hash algorithm, \
3working at speeds close to RAM limits."
4HOMEPAGE = "http://www.xxhash.com/"
5LICENSE = "BSD-2-Clause & GPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b335320506abb0505437e39295e799cb"
7
William A. Kennington IIIac69b482021-06-02 12:28:27 -07008SRC_URI = "git://github.com/Cyan4973/xxHash.git;branch=release;protocol=git \
9 file://0001-Makefile-escape-special-regex-characters-in-paths.patch \
10 "
Andrew Geissler95ac1b82021-03-31 14:34:31 -050011UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
12
13SRCREV = "94e5f23e736f2bb67ebdf90727353e65344f9fc0"
14
15S = "${WORKDIR}/git"
16
17do_compile () {
18 oe_runmake all
19}
20
21do_install () {
22 oe_runmake DESTDIR=${D} install
23}
24
25BBCLASSEXTEND = "native nativesdk"