Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Key/value database library with extensible hashing" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Library of database functions that use extensible hashing \ |
| 3 | and work similar to the standard UNIX dbm. These routines are provided \ |
| 4 | to a programmer needing to create and manipulate a hashed database." |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 5 | HOMEPAGE = "http://www.gnu.org/software/gdbm/" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "GPLv3" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24" |
| 9 | |
| 10 | |
| 11 | SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \ |
| 12 | file://run-ptest \ |
| 13 | file://ptest.patch \ |
| 14 | " |
| 15 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 16 | SRC_URI[md5sum] = "aeb29c6a90350a4c959cd1df38cd0a7e" |
| 17 | SRC_URI[sha256sum] = "37ed12214122b972e18a0d94995039e57748191939ef74115b1d41d8811364bc" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | |
| 19 | inherit autotools gettext texinfo lib_package ptest |
| 20 | |
| 21 | # Needed for dbm python module |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | EXTRA_OECONF = "--enable-libgdbm-compat --without-readline" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | |
| 24 | # Stop presence of dbm/nbdm on the host contaminating builds |
| 25 | CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no" |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | do_install:append () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find |
| 31 | # these headers |
| 32 | install -d ${D}${includedir}/gdbm |
| 33 | ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h |
| 34 | ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h |
| 35 | } |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | RDEPENDS:${PN}-ptest += "diffutils ${PN}-bin" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 38 | |
| 39 | do_compile_ptest() { |
| 40 | oe_runmake -C tests buildtests |
| 41 | } |
| 42 | |
| 43 | PACKAGES =+ "${PN}-compat \ |
| 44 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | FILES:${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 46 | " |