blob: 9699405753da20574c2c7e88003a9107ad742a35 [file] [log] [blame]
Karthikeyan Pasupathi36f035b2022-08-28 17:35:29 +05301FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3DEFAULT_TARGETS = " \
4 multi-user.target.requires/obmc-host-reset@{}.target \
Potin Lai0622e1d2022-12-21 13:53:17 +08005 multi-user.target.wants/phosphor-discover-system-state@{}.service \
Karthikeyan Pasupathi36f035b2022-08-28 17:35:29 +05306 obmc-chassis-poweron@{}.target.wants/chassis-poweron@{}.service \
7 obmc-chassis-hard-poweroff@{}.target.wants/chassis-poweroff@{}.service \
8 obmc-host-shutdown@{}.target.wants/host-poweroff@{}.service \
9 obmc-host-start@{}.target.wants/host-poweron@{}.service \
10 obmc-host-reboot@{}.target.wants/host-powercycle@{}.service \
11"
12
13SRC_URI:append:greatlakes = " \
14 file://chassis-poweroff@.service \
15 file://chassis-poweron@.service \
16 file://host-poweroff@.service \
17 file://host-poweron@.service \
18 file://host-powercycle@.service \
19 file://chassis-poweroff \
20 file://chassis-poweron \
21 file://host-poweroff \
22 file://host-poweron \
23 file://host-powercycle \
24 file://power-cmd \
25 "
26
27RDEPENDS:${PN}:append:greatlakes = " bash"
28
29do_install:append:greatlakes() {
30 install -d ${D}${systemd_system_unitdir}
31 install -m 0644 ${WORKDIR}/*.service ${D}${systemd_system_unitdir}/
32
33 install -d ${D}${libexecdir}
34 install -m 0777 ${WORKDIR}/chassis-poweroff ${D}${libexecdir}/
35 install -m 0777 ${WORKDIR}/chassis-poweron ${D}${libexecdir}/
36 install -m 0777 ${WORKDIR}/host-poweroff ${D}${libexecdir}/
37 install -m 0777 ${WORKDIR}/host-poweron ${D}${libexecdir}/
38 install -m 0777 ${WORKDIR}/host-powercycle ${D}${libexecdir}/
39 install -m 0777 ${WORKDIR}/power-cmd ${D}${libexecdir}/
40}
41FILES:${PN} += " /lib/systemd/system/*.service"